You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
21 lines
704 B
21 lines
704 B
ympd is implemented only in C
|
|
|
|
By default, CMake assumes that the project is using both C and C++. By
|
|
explicitly passing 'C' as argument of the project() macro, we tell
|
|
CMake that only C is used, which prevents CMake from checking if a C++
|
|
compiler exists.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/CMakeLists.txt
|
|
===================================================================
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -1,6 +1,6 @@
|
|
cmake_minimum_required(VERSION 2.6)
|
|
|
|
-project (ympd)
|
|
+project (ympd C)
|
|
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${PROJECT_SOURCE_DIR}/cmake/")
|
|
set(CPACK_PACKAGE_VERSION_MAJOR "1")
|
|
set(CPACK_PACKAGE_VERSION_MINOR "2")
|
|
|