You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
82 lines
2.8 KiB
82 lines
2.8 KiB
From 9382ae2431d2962c430e7149302c8690f5bc159c Mon Sep 17 00:00:00 2001
|
|
From: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
|
Date: Sun, 10 Jul 2016 15:06:15 +0200
|
|
Subject: [PATCH] build: do not use -Werror
|
|
|
|
Warnings come and go with various compiler versions, so using -Werror is
|
|
prone to cause build failures with various compiler versions, especially
|
|
newer versions that introduce new warnings.
|
|
|
|
Remove use of -Werror.
|
|
|
|
[Vincent: tweak patch for 20170531 release]
|
|
[Bernd: tweak patch for 20191018 release]
|
|
|
|
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
|
|
Signed-off-by: "Vicente Olivert Riera" <Vincent.Riera@imgtec.com>
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
---
|
|
generate/unix/Makefile.config | 1 -
|
|
generate/unix/iasl/Makefile | 16 ++++++++--------
|
|
2 files changed, 8 insertions(+), 9 deletions(-)
|
|
|
|
diff --git a/generate/unix/Makefile.config b/generate/unix/Makefile.config
|
|
index c28e8a9b1..7064bed97 100644
|
|
--- a/generate/unix/Makefile.config
|
|
+++ b/generate/unix/Makefile.config
|
|
@@ -204,7 +204,6 @@ CWARNINGFLAGS = \
|
|
-Wall\
|
|
-Wbad-function-cast\
|
|
-Wdeclaration-after-statement\
|
|
- -Werror\
|
|
-Wformat=2\
|
|
-Wmissing-declarations\
|
|
-Wmissing-prototypes\
|
|
diff --git a/generate/unix/iasl/Makefile b/generate/unix/iasl/Makefile
|
|
index 47ea73cab..2c756af79 100644
|
|
--- a/generate/unix/iasl/Makefile
|
|
+++ b/generate/unix/iasl/Makefile
|
|
@@ -360,32 +360,32 @@ $(OBJDIR)/prparserparse.c $(OBJDIR)/prparser.y.h : $(ASL_COMPILER)/prparse
|
|
#
|
|
$(OBJDIR)/aslcompilerlex.o : $(OBJDIR)/aslcompilerlex.c
|
|
@echo "- " "Intermediate" $<
|
|
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
|
|
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
|
|
|
|
$(OBJDIR)/aslcompilerparse.o : $(OBJDIR)/aslcompilerparse.c
|
|
@echo "- " "Intermediate" $<
|
|
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
|
|
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
|
|
|
|
$(OBJDIR)/dtcompilerparserlex.o : $(OBJDIR)/dtcompilerparserlex.c
|
|
@echo "- " "Intermediate" $<
|
|
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
|
|
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
|
|
|
|
$(OBJDIR)/dtcompilerparserparse.o : $(OBJDIR)/dtcompilerparserparse.c
|
|
@echo "- " "Intermediate" $<
|
|
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
|
|
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
|
|
|
|
$(OBJDIR)/dtparserlex.o : $(OBJDIR)/dtparserlex.c
|
|
@echo "- " "Intermediate" $<
|
|
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
|
|
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
|
|
|
|
$(OBJDIR)/dtparserparse.o : $(OBJDIR)/dtparserparse.c
|
|
@echo "- " "Intermediate" $<
|
|
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
|
|
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
|
|
|
|
$(OBJDIR)/prparserlex.o : $(OBJDIR)/prparserlex.c
|
|
@echo "- " "Intermediate" $<
|
|
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
|
|
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
|
|
|
|
$(OBJDIR)/prparserparse.o : $(OBJDIR)/prparserparse.c
|
|
@echo "- " "Intermediate" $<
|
|
- @$(CC) -c $(CFLAGS) -Wall -Werror -o$@ $<
|
|
+ @$(CC) -c $(CFLAGS) -Wall -o$@ $<
|
|
--
|
|
2.20.1
|
|
|
|
|